Lista de exercícios resolvidos

  1. Elabore um fluxograma e um programa em Português Estruturado que calcule e mostre o cubo de cada número inteiro contido em um intervalo cujos extremos são fornecidos pelo usuário.

Escreva: “ Insira o intervalo desejado para que o programa execute a expoenciaçao”

Escreva: “ De?”

Leia: inicio

Escreva: “ Até?”

Leia: fim

_________________________________________________________________________________________

Para cont de inicio até fim passo 1 faça

Num<- cont

Result <-num^ 3

Escreva: “ O numero” , cont , “ elevado ao cubo é:” , result

Fim_para

Fim

_________________________________________________________________________________________

Cont<- inicio

Enquanto ( cont<= fim) faça

Num<- cont

Result <-num^ 3

Escreva: “ O numero” , cont , “ elevado ao cubo é:” , result

Fim_enquanto

fim

________________________________________________________________________________________

Cont<- inicio

Repita

Num<- cont

Result <-num^ 3

Escreva: “ O numero” , cont , “ elevado ao cubo é:” , result

Até que (cont > fim)

fim

Para a aprovação de um exame o Candidato precisa realizar quatro provas (português, matemática, informática e atualidades), cada prova tem valor 10. Para aprovação o candidato:

- Não pode ter nota <4 em nenhuma prova

- deve ter no mínimo uma pontuação total de 20 acertos.

Faça um algoritmo que receba o nome do candidato suas notas e ao final mostre seus resultados, o algoritmo deve ser repetido, quantas vezes seu utilizador desejar….

Concurso

Variáveis

cont: inteiroreal

npor, nmat, ninfo, natu, ngeral: real

resp: caracter

Inicio

cont <-1

Resp<-s

Enquanto (resp = S) faca

Escreva: “qual nome do candidato” , cont

Leia nome

Escreva: “qual nota de português”

Leia: nport

Escreva: “qual nota de matematica”

Leia: nmat

Escreva: “qual nota de Informatica”

Leia: ninfo

Escreva: “qual nota de Atualidades”

Leia: natu

Se (npor>=4) .e.(nmat>=4) .e. (ninfo>=4).e.(natu>=4).e.(ngeral>=20) entao

Escreva: “O candidato” , cont “-“ ,nome “está aprovado”

Senão

Escreva: “O candidato” , cont “-“ ,nome “está reprovado”

Fim-se

Deseja cadastrar novo candidato digite (S)im ou (N)ão

Leia resp

Cont<- cont +1

Fim enquanto

Em uma loja os vendedores tem direito a 15% de comissão no fim do mês sobre o total de vendas realizadas por eles. Faça um algoritmo que ajude ao dono da loja fechar as comissões do fim deste mês dos vendedores da loja, seu algoritimo deve identificar o vendedor e cadastrar individualmente as vendas de cada vendedor para que ao final possa mostrar o total em R$ de quanto aquele vendedor vendeu e consequentemente qual o seu salario no fim do mês

VENDA

Variáveis

Vendedor, Resp_Venda, resp: caracter

Cont_vend: inteiro

V_venda, comiss: real

INICIO

Cont_venda <-1

Resp <-S

Repita

Escreva: “nome do vendedor”

Leia: vendedor

Enquanto (Resp_venda = S) faca

Escreva: Qual o valor da venda?”, cont_venda

Leia: V_venda

Total_vendas <-Total_vendas + V_venda

Cont_venda <- cont_venda + 1

Deseja cadastrar nova Venda digite (S)im ou (N)ão

Leia resp_venda

Fim Enquanto

Comiss<- Total_venda * 0,15

Escreva “A comissão do Vendedor” ,vendedor “foi de R$”, Comiss

Deseja fechar comissão de outro vendedor? (S)im ou (N)ão?

Leia: resp

Até que (resp =N)

fim

  1. Fazer um algoritmo que imprima todos os números de 100 até 1.

Variáveis:

Cont: inteiro

Inicio:

Cont <-1

Repita

Escreva: Cont

Ate_que (cont<1)

fim

  1. Fazer um algoritmo que imprima todos os números pares no intervalo 1-100.

Dessa forma vai de 2 em 2

Tipo 2,4,6.....

Duas formas:

Para cont de 2 ate 100, passo 2 faça

Escreva “Imprimindo números pares de 0 a 100” , cont

Fim_para

Ou

Enquanto (cont<=100)faça

Se (Cont MOD 2=0) entao

Escreva “Imprimindo números pares de 0 a 100” , cont

Fim-se

Cont  cont+1

Fim enquanto

fim

  1. Faça um programa que exiba todos os números múltiplos de 5, entre 1000 e 2000

Para cont de 1000 ate 2000, passo 1 faça

Se(cont MOD 5=0)entao

Imprima: cont

Fim-se

Fim_para

Fim

  1. Adaptado (Enade 2008). Pseudocódigo é uma forma genérica de se escrever um algoritmo, da forma mais detalhada possível, utilizando-se uma linguagem simples, nativa a quem o escreve, de modo a ser entendida sem necessidade de se conhecer a sintaxe de uma linguagem de programação específica. Apresenta-se abaixo o pseudocódigo de um algoritmo capaz de resolver equações diferenciais da forma dx(t)/dt = g(x), frequentemente encontradas em problemas de modelagem em Engenharia.

Uma forma equivalente, e algumas vezes complementar, ao pseudocódigo, utilizada para se representar um algoritmo é o diagrama de fluxos (fluxograma). Escrever um fluxograma que represente o pseudocódigo descrito acima.

  1. Escreva um fluxograma e um programa em Português Estrutura que mostre os resultados da tabuada de um número inteiro e positivo qualquer fornecido pelo usuário.

Variáveis:

         numero, controle : inteiro

  inicio

      escreva ("Informe um número inteiro positivo para tabuada: ")

      leia (numero)

      para controle de 1 ate 10 passo 1 faca

          escreval(numero, " x ",controle," = ", (numero * controle) )

      fimpara

fimalgoritmo

 

Comentários